Friday, February 06, 2009

Oh yea, I'm cool. well at least educatable...

I can't believe all I've done today. I couldn't have done it that long ago. Today at random free moments, through the command line interface I've:
  • Checked the status of an apparently non-responding virtual machine
  • entered it as a root user from the host machine
  • navigated to /home and found the user wasn't dgroos but instead groos--got it!
  • sshed into the groos account, tried to sudo but couldn't as not a sudoer.
  • found how to add myself to the sudo group, tried to edit the sudoer list with vi but said I needed to use visudo or something. But, i found that there was a user in the sudo list called dgroos! but, there wasn't a user named dgroos so I adduser dgroos (as the root user, logged in from the host server), logged out
  • then sshed into the virtual machine, sudo mv the file to the /srv folder.
  • then tar -xvzf the plone installer, then reading the README.txt with vi.
  • sudo ./srv/InstallerFolder/install.sh (had to use the absolute path--I guess the command wasn't in the PATH or something).
  • But...got the error message that gcc wasn't present.
  • So figured out that I needed to install it so installed a bunch of useful stuff with:
    apt-get install gcc build-essential
  • then tried to install plone but still no luck--still no gcc...
  • So found I needed to upgraded and did so.
  • but still no luck, so apt-got gcc ;-)
  • And then... Well at this very minute (minutes) I'm watching plone install... here's a screen cast :)
video
  • And now... it appears that it's all installed. I'll check to see if it is working...
  • it installed a zeo cluster? oops.
  • Checked the install script but don't really get it.
  • googled some more and remembered you have to write: sudo ./install.sh standalone
  • did that and it still installed a ZEO...
  • Hmmm... time to get some personal help, not just google help

1 comment:

  1. The Plone chat rooms are a useful way to get help if you need immediate assistance:

    http://plone.org/support/chat

    ReplyDelete